$re = '/((\'|\")((?:ASIA|AKIA|AROA|AIDA)([A-Z0-7]{16}))(\'|\").*?(\n^.*?){0,4}((\'|\")[a-zA-Z0-9+/]{40}(\'|\"))+|(\'|\")[a-zA-Z0-9+/]{40}(\'|\").*?(\n^.*?){0,3}(\'|\")((?:ASIA|AKIA|AROA|AIDA)([A-Z0-7]{16}))(\'|\"))+/m';
$str = 'import json
from amazon_pay.client import AmazonPayClient
#client = AmazonPayClient(
# mws_access_key=\'AKIAJIUGYOGHT2ONMCOQ\',
# mws_secret_key=\'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\',
# merchant_id=\'A2GWANJA6L1J87\',
# region=\'na\',
# currency_code=\'USD\',
# sandbox=True)
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);