use strict;
my $str = 'import json
from amazon_pay.client import AmazonPayClient
#client = AmazonPayClient(
# mws_access_key=\'AKIAJIUGYOGHT2ONMCOQ\',
# mws_secret_key=\'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\',
# merchant_id=\'A2GWANJA6L1J87\',
# region=\'na\',
# currency_code=\'USD\',
# sandbox=True)
';
my $regex = qr/(('|\")((?:ASIA|AKIA|AROA|AIDA)([A-Z0-7]{16}))('|\").*?(\n^.*?){0,4}(('|\")[a-zA-Z0-9+/]{40}('|\"))+|('|\")[a-zA-Z0-9+/]{40}('|\").*?(\n^.*?){0,3}('|\")((?:ASIA|AKIA|AROA|AIDA)([A-Z0-7]{16}))('|\"))+/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}