import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(('|\\\")((?:ASIA|AKIA|AROA|AIDA)([A-Z0-7]{16}))('|\\\").*?(\\n^.*?){0,4}(('|\\\")[a-zA-Z0-9+/]{40}('|\\\"))+|('|\\\")[a-zA-Z0-9+/]{40}('|\\\").*?(\\n^.*?){0,3}('|\\\")((?:ASIA|AKIA|AROA|AIDA)([A-Z0-7]{16}))('|\\\"))+";
final String string = "import json\n\n"
+ "from amazon_pay.client import AmazonPayClient\n\n"
+ "#client = AmazonPayClient(\n"
+ "# mws_access_key='AKIAJIUGYOGHT2ONMCOQ',\n"
+ "# mws_secret_key='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',\n"
+ "# merchant_id='A2GWANJA6L1J87',\n"
+ "# region='na',\n"
+ "# currency_code='USD',\n"
+ "# sandbox=True)\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}