using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(('|\"")((?:ASIA|AKIA|AROA|AIDA)([A-Z0-7]{16}))('|\"").*?(\n^.*?){0,4}(('|\"")[a-zA-Z0-9+/]{40}('|\""))+|('|\"")[a-zA-Z0-9+/]{40}('|\"").*?(\n^.*?){0,3}('|\"")((?:ASIA|AKIA|AROA|AIDA)([A-Z0-7]{16}))('|\""))+";
string input = @"import json
from amazon_pay.client import AmazonPayClient
#client = AmazonPayClient(
# mws_access_key='AKIAJIUGYOGHT2ONMCOQ',
# mws_secret_key='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',
# merchant_id='A2GWANJA6L1J87',
# region='na',
# currency_code='USD',
# sandbox=True)
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}