// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)(('|\")((?:ASIA|AKIA|AROA|AIDA)([A-Z0-7]{16}))('|\").*?(\n^.*?){0,4}(('|\")[a-zA-Z0-9+/]{40}('|\"))+|('|\")[a-zA-Z0-9+/]{40}('|\").*?(\n^.*?){0,3}('|\")((?:ASIA|AKIA|AROA|AIDA)([A-Z0-7]{16}))('|\"))+"#).unwrap();
let string = "import json
from amazon_pay.client import AmazonPayClient
#client = AmazonPayClient(
# mws_access_key='AKIAJIUGYOGHT2ONMCOQ',
# mws_secret_key='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',
# merchant_id='A2GWANJA6L1J87',
# region='na',
# currency_code='USD',
# sandbox=True)
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}