#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(?:[a-z]|\B[A-Z]+)\K(?=[A-Z]\B|\d+)"
Local $sString = "SomeEquipmentHere" & @CRLF & _
"ABSBrakes" & @CRLF & _
"CDRadio" & @CRLF & _
"Valve14" & @CRLF & _
"AC-DC" & @CRLF & _
"WTF"
Local $sSubst = " "
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)