re = /(?:[a-z]|\B[A-Z]+)\K(?=[A-Z]\B|\d+)/m
str = 'SomeEquipmentHere
ABSBrakes
CDRadio
Valve14
AC-DC
WTF'
subst = ' '
result = str.gsub(re, subst)
# Print the result of the substitution
puts result