const regex = /(?:[a-z]|\B[A-Z]+)\K(?=[A-Z]\B|\d+)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:[a-z]|\\B[A-Z]+)\\K(?=[A-Z]\\B|\\d+)', 'gm')
const str = `SomeEquipmentHere
ABSBrakes
CDRadio
Valve14
AC-DC
WTF`;
const subst = ` `;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);