$re = '/(?:[a-z]|\B[A-Z]+)\K(?=[A-Z]\B|\d+)/m';
$str = 'SomeEquipmentHere
ABSBrakes
CDRadio
Valve14
AC-DC
WTF';
$subst = " ";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;