use strict;
my $str = 'SomeEquipmentHere
ABSBrakes
CDRadio
Valve14
AC-DC
WTF';
my $regex = qr/(?:[a-z]|\B[A-Z]+)\K(?=[A-Z]\B|\d+)/mp;
my $subst = ' ';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";