# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(>[^<]*)(search string)([^>]*<)/$1transform string$3/gm;t' <<< "<td>test regexp find search string in text and tags<\td>"