$re = '/(>[^<]*)(search string)([^>]*<)/m';
$str = '<td>test regexp find search string in text and tags<\\td>';
$subst = "$1transform string$3";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;