use strict;
my $str = '<td>test regexp find search string in text and tags<\\td>';
my $regex = qr/(>[^<]*)(search string)([^>]*<)/mp;
my $subst = '$1transform string$3';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";