re = /(>[^<]*)(search string)([^>]*<)/m
str = '<td>test regexp find search string in text and tags<\\td>'
subst = '$1transform string$3'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result