#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(>[^<]*)(search string)([^>]*<)"
Local $sString = "<td>test regexp find search string in text and tags<\td>"
Local $sSubst = "$1transform string$3"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)