#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(?<=id=")([^"\n]+)"[^#\n]+#\K"
Local $sString = "<li><a id="a4.9" href="trigger_marker.html#">Trigger marker</a> </li>" & @CRLF & _
"<li><a id="a4.10" href="timedelayarrow.html#">Time-delay arrow</a> </li>" & @CRLF & _
"<li><a id="a4.11" href="spectrumview.html#">Spectrum view</a> </li>"
Local $sSubst = "\1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)