const regex = /(?<=id=")([^"\n]+)"[^#\n]+#\K/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=id=")([^"\\n]+)"[^#\\n]+#\\K', 'gm')
const str = `<li><a id="a4.9" href="trigger_marker.html#">Trigger marker</a> </li>
<li><a id="a4.10" href="timedelayarrow.html#">Time-delay arrow</a> </li>
<li><a id="a4.11" href="spectrumview.html#">Spectrum view</a> </li>`;
const subst = `\1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);