import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=id=\")([^\"\\n]+)\"[^#\\n]+#\\K";
final String string = "<li><a id=\"a4.9\" href=\"trigger_marker.html#\">Trigger marker</a> </li>\n"
+ "<li><a id=\"a4.10\" href=\"timedelayarrow.html#\">Time-delay arrow</a> </li>\n"
+ "<li><a id=\"a4.11\" href=\"spectrumview.html#\">Spectrum view</a> </li>";
final String subst = "\\1";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}