re = /(?<=id=")([^"\n]+)"[^#\n]+#\K/m
str = '<li><a id="a4.9" href="trigger_marker.html#">Trigger marker</a> </li>
<li><a id="a4.10" href="timedelayarrow.html#">Time-delay arrow</a> </li>
<li><a id="a4.11" href="spectrumview.html#">Spectrum view</a> </li>'
subst = '\\1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result