using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=id="")([^""\n]+)""[^#\n]+#\K";
string substitution = @"\1";
string input = @"<li><a id=""a4.9"" href=""trigger_marker.html#"">Trigger marker</a> </li>
<li><a id=""a4.10"" href=""timedelayarrow.html#"">Time-delay arrow</a> </li>
<li><a id=""a4.11"" href=""spectrumview.html#"">Spectrum view</a> </li>";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}