# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^(?!.*test)([^+]*)\+.*/\1/gm;t' <<< "Col+djek
Col_test+deg
Col_+dege
Col_+test"