#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^(?!.*test)([^+]*)\+.*"
Local $sString = "Col+djek" & @CRLF & _
"Col_test+deg" & @CRLF & _
"Col_+dege" & @CRLF & _
"Col_+test"
Local $sSubst = "\1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)