re = /^(?!.*test)([^+]*)\+.*/m
str = 'Col+djek
Col_test+deg
Col_+dege
Col_+test'
subst = '\\1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result