use strict;
my $str = 'Col+djek
Col_test+deg
Col_+dege
Col_+test';
my $regex = qr/^(?!.*test)([^+]*)\+.*/mp;
my $subst = '\\1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";