using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?!.*test)([^+]*)\+.*";
string substitution = @"\1";
string input = @"Col+djek
Col_test+deg
Col_+dege
Col_+test";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}