# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(.*)\\/jobs\\/\?(.*)/$1\\/job\\/$2/g;t' <<< "https://www.test.com/jobs/?test"