using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(.*)\/jobs\/\?(.*)";
string substitution = @"$1\/job\/$2";
string input = @"https://www.test.com/jobs/?test";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}