// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(.*)\/jobs\/\?(.*)").unwrap();
let string = "https://www.test.com/jobs/?test";
let substitution = "$1\\/job\\/$2";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}