package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(.*)\/jobs\/\?(.*)`)
var str = `https://www.test.com/jobs/?test`
var substitution = "$1\/job\/$2"
fmt.Println(re.ReplaceAllString(str, substitution))
}