$re = '/(.*)\/jobs\/\?(.*)/';
$str = 'https://www.test.com/jobs/?test';
$subst = "$1\/job\/$2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;