const regex = /(.*)\/jobs\/\?(.*)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(.*)\\\/jobs\\\/\\?(.*)', 'g')
const str = `https://www.test.com/jobs/?test`;
const subst = `$1\/job\/$2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);