#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(^.+[^/f/])"
Local $sString = "/televizory-i-cifrovoe-tv/televizory-65?reff=menu_main" & @CRLF & _
"/televizory-i-cifrovoe-tv/televizory-65/f/category=4k-uhd-televizory-1682?reff=menu_main" & @CRLF & _
"/televizory-i-cifrovoe-tv/televizory-65/f/category=led-8k-televizory-6947?reff=menu_main" & @CRLF & _
"/televizory-i-cifrovoe-tv-1/televizory-65/f/smart-tv=da?reff=menu_main" & @CRLF & _
"/televizory-i-cifrovoe-tv/televizory-65/f/kvantovij_tochki_tv=da?reff=menu_main" & @CRLF & _
"/televizory-i-cifrovoe-tv/televizory-65/f/category=oled-televizory-1987?reff=menu_main" & @CRLF & _
"/televizory-i-cifrovoe-tv-1/televizory-65/f/collection_bottom=seriya-frame?reff=menu_main"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")