using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(^.+[^/f/])";
string input = @"/televizory-i-cifrovoe-tv/televizory-65?reff=menu_main
/televizory-i-cifrovoe-tv/televizory-65/f/category=4k-uhd-televizory-1682?reff=menu_main
/televizory-i-cifrovoe-tv/televizory-65/f/category=led-8k-televizory-6947?reff=menu_main
/televizory-i-cifrovoe-tv-1/televizory-65/f/smart-tv=da?reff=menu_main
/televizory-i-cifrovoe-tv/televizory-65/f/kvantovij_tochki_tv=da?reff=menu_main
/televizory-i-cifrovoe-tv/televizory-65/f/category=oled-televizory-1987?reff=menu_main
/televizory-i-cifrovoe-tv-1/televizory-65/f/collection_bottom=seriya-frame?reff=menu_main";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}