import re
regex = re.compile(r"(^.+[^/f/])", flags=re.MULTILINE)
test_str = ("/televizory-i-cifrovoe-tv/televizory-65?reff=menu_main\n"
"/televizory-i-cifrovoe-tv/televizory-65/f/category=4k-uhd-televizory-1682?reff=menu_main\n"
"/televizory-i-cifrovoe-tv/televizory-65/f/category=led-8k-televizory-6947?reff=menu_main\n"
"/televizory-i-cifrovoe-tv-1/televizory-65/f/smart-tv=da?reff=menu_main\n"
"/televizory-i-cifrovoe-tv/televizory-65/f/kvantovij_tochki_tv=da?reff=menu_main\n"
"/televizory-i-cifrovoe-tv/televizory-65/f/category=oled-televizory-1987?reff=menu_main\n"
"/televizory-i-cifrovoe-tv-1/televizory-65/f/collection_bottom=seriya-frame?reff=menu_main")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")