package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?mx) # x- modifiers to add comments in regex
#. #any character, except newline
#\s. #only space and newline characters
#\w+ #Word quantifiers to match 1 or more words
[\ \.\-]`)
var str = `123.345
123 345
123-456`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}