re = /(?mx) # x- modifiers to add comments in regex
#. #any character, except newline
#\s. #only space and newline characters
#\w+ #Word quantifiers to match 1 or more words
[\ \.\-]/m
str = '123.345
123 345
123-456'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end