// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(?mx) # x- modifiers to add comments in regex
#. #any character, except newline
#\s. #only space and newline characters
#\w+ #Word quantifiers to match 1 or more words
[\ \.\-]").unwrap();
let string = "123.345
123 345
123-456";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}