use strict;
my $str = '123.345
123 345
123-456';
my $regex = qr/(?mx) # x- modifiers to add comments in regex
#. #any character, except newline
#\s. #only space and newline characters
#\w+ #Word quantifiers to match 1 or more words
[\ \.\-]/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}