using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^@id *= *1[\r\n]+((?:[^#]*#)+?)(?<=^#)$";
string input = @"alskdfkldsfjd
# thekt nect
@id=2
akdfjdkf
adlksfj
@id=1
adksfklasdjf // This line should be captured
asdlkfjdkfj // And this one
@id=3 // this one
dkfjadklfja // And #
#
kdsalfjaslkdf
#";
RegexOptions options = RegexOptions.Multiline | RegexOptions.Singleline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}