re = /^@id *= *1[\r\n]+((?:[^#]*#)+?)(?<=^#)$/m
str = 'alskdfkldsfjd
# thekt nect
@id=2
akdfjdkf
adlksfj
@id=1
adksfklasdjf // This line should be captured
asdlkfjdkfj // And this one
@id=3 // this one
dkfjadklfja // And #
#
kdsalfjaslkdf
#'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end