import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^@id *= *1[\\r\\n]+((?:[^#]*#)+?)(?<=^#)$";
final String string = "alskdfkldsfjd\n"
+ "# thekt nect\n"
+ "@id=2\n"
+ "akdfjdkf\n"
+ "adlksfj\n"
+ "@id=1\n"
+ "adksfklasdjf // This line should be captured\n"
+ "asdlkfjdkfj // And this one\n"
+ "@id=3 // this one\n"
+ "dkfjadklfja // And #\n"
+ "#\n"
+ "kdsalfjaslkdf\n"
+ "#";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}