$re = '/^@id *= *1[\r\n]+((?:[^#]*#)+?)(?<=^#)$/ms';
$str = 'alskdfkldsfjd
# thekt nect
@id=2
akdfjdkf
adlksfj
@id=1
adksfklasdjf // This line should be captured
asdlkfjdkfj // And this one
@id=3 // this one
dkfjadklfja // And #
#
kdsalfjaslkdf
#';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);