const regex = /^https?:\/\/(?:www\.)?(.{25}(?:(?<=\w)\w*|\b)).{5,}$/s;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^https?:\\\/\\\/(?:www\\.)?(.{25}(?:(?<=\\w)\\w*|\\b)).{5,}$', 's')
const str = `https://forum.textpattern.com/viewtopic.php?pid=338199#p338199`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);