$re = '/^https?:\/\/(?:www\.)?(.{25}(?:(?<=\w)\w*|\b)).{5,}$/s';
$str = 'https://forum.textpattern.com/viewtopic.php?pid=338199#p338199';
$subst = "$1";
$result = preg_replace($re, $subst, $str, 1);
echo "The result of the substitution is ".$result;