re = /^https?:\/\/(?:www\.)?(.{25}(?:(?<=\w)\w*|\b)).{5,}$/
str = 'https://forum.textpattern.com/viewtopic.php?pid=338199#p338199'
subst = '$1'
result = str.sub(re, subst)
# Print the result of the substitution
puts result