import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?=.{2,5}$)[a-z][a-z0-9]*[0-9][a-z0-9]*$";
final String string = "re11e\n"
+ "a1aaa\n\n"
+ "aaaa1\n"
+ "a1000\n"
+ "1aaaa\n"
+ "11111\n"
+ "q99q9";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}