const regex = /^(?=.{2,5}$)[a-z][a-z0-9]*[0-9][a-z0-9]*$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?=.{2,5}$)[a-z][a-z0-9]*[0-9][a-z0-9]*$', 'gm')
const str = `re11e
a1aaa
aaaa1
a1000
1aaaa
11111
q99q9`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}