import re
regex = re.compile(r"^(?=.{2,5}$)[a-z][a-z0-9]*[0-9][a-z0-9]*$", flags=re.MULTILINE)
test_str = ("re11e\n"
"a1aaa\n\n"
"aaaa1\n"
"a1000\n"
"1aaaa\n"
"11111\n"
"q99q9")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")