use strict;
my $str = 're11e
a1aaa
aaaa1
a1000
1aaaa
11111
q99q9';
my $regex = qr/^(?=.{2,5}$)[a-z][a-z0-9]*[0-9][a-z0-9]*$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}