#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[a-z][-a-z0-9]{4,28}[a-z0-9]{1}$"
Local $sString = "rabbithole-007" & @CRLF & _
"r340j-" & @CRLF & _
"8jh" & @CRLF & _
"jo9" & @CRLF & _
"d366gg-" & @CRLF & _
"synthetic-cargo-343207" & @CRLF & _
"d4jikkj34jk34j34jk3jk4j3k4h3jkh4jk3nbdfjk4-4jk3k4j-" & @CRLF & _
"d4jikkj34jk34j34jk3jk4j" & @CRLF & _
"d4jikkj34jk34j34jk3jk4j3k4h3jkh4jk3nbdfjk4-4jk3k4jskdnskjdsjkdnfksfkdjfkdfjkdfdjlkfjdlkfjlkdjflkjdfjdlkfjldkjflkd" & @CRLF & _
"rabbit-hole-integration-007"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")